Planteamos un laboratorio para que la comunidad lo pueda resolver.

Ya tenemos parte de la solución con toda la parte de Routing acá en los siguientes outputs de cada routers (está realizado sobre equipamiento real), en algunos dias publicaremos la parte de switching.

Esto es lo que hicimos:

-Configurar interfaces con el direccionamiento ip respectivo.
-Configurar protocolos de enrutamiento según el diagrama.
-Configurar la redistribución de protocolos entre EIGRP y OSPF.
-Configurar ruta default en R4 hacia loopback 0 y propagarla.
-R4 es Dhcp server para las vlan 10,20,30,40,50,60; excluya las primeras 10 ip válidas del segmento de red.
-R4 es NTP Server de todos los routers y switches.


Van las configuraciones:

R1#show run

Building configuration...

Current configuration : 1497 bytes

!

! NVRAM config last updated at 22:06:45 UTC Fri Dec 30 2016

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

ip ips po max-events 100

no ftp-server write-enable

!

voice-card 0

no dspfarm

!

!

no crypto isakmp ccm

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface FastEthernet0/1.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface FastEthernet0/1.40

no cdp enable

!

interface Serial0/0/0

ip address 201.0.0.1 255.255.255.0

no fair-queue

!

interface Serial0/1/0

no ip address

shutdown

clockrate 2000000

!

router ospf 100

log-adjacency-changes

network 192.168.10.1 0.0.0.0 area 0

network 192.168.20.1 0.0.0.0 area 0

network 192.168.30.1 0.0.0.0 area 0

network 192.168.40.1 0.0.0.0 area 0

network 201.0.0.1 0.0.0.0 area 0

!

ip classless

!

!

ip http server

no ip http secure-server

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

ntp clock-period 17179942

ntp server 199.45.201.99

!

End


R2#show run

Building configuration...

Current configuration : 1782 bytes

!

! Last configuration change at 21:59:52 UTC Fri Dec 30 2016

! NVRAM config last updated at 22:06:57 UTC Fri Dec 30 2016

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

ip cef

!

!

no ip domain lookup

ip ips po max-events 100

no ftp-server write-enable

!

voice-card 0

no dspfarm

!

no crypto isakmp ccm

!

!

!

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.40

encapsulation dot1Q 40

ip address 192.168.40.1 255.255.255.0

!

interface FastEthernet0/1.50

encapsulation dot1Q 50

ip address 192.168.50.1 255.255.255.0

!

interface FastEthernet0/1.60

encapsulation dot1Q 60

ip address 192.168.60.1 255.255.255.0

!

interface FastEthernet0/1.90

encapsulation dot1Q 90

ip address 192.168.90.1 255.255.255.0

!

interface FastEthernet0/1.99

encapsulation dot1Q 99

ip address 192.168.99.1 255.255.255.0

!

interface Serial0/0/0

ip address 202.0.0.1 255.255.255.0

!

interface Serial0/1/0

no ip address

shutdown

!

router ospf 100

log-adjacency-changes

network 192.168.40.1 0.0.0.0 area 0

network 192.168.50.1 0.0.0.0 area 0

network 192.168.60.1 0.0.0.0 area 0

network 192.168.90.1 0.0.0.0 area 0

network 192.168.99.1 0.0.0.0 area 0

network 202.0.0.1 0.0.0.0 area 0

!

ip classless

!

!

ip http server

no ip http secure-server

!

control-plane

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

warm-reboot

scheduler allocate 20000 1000

ntp clock-period 17179934

ntp server 199.45.201.99

!

end


R3#show run

Building configuration...

Current configuration : 1261 bytes

!

! NVRAM config last updated at 22:07:08 UTC Fri Dec 30 2016

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

ip audit po max-events 100

!

!

interface Loopback1

no ip address

!

interface FastEthernet0/0

ip address 203.0.0.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 202.0.0.2 255.255.255.0

clock rate 2000000

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/1

ip address 201.0.0.2 255.255.255.0

clock rate 2000000

!

router eigrp 35

redistribute ospf 100 metric 100000 10 255 1 1541

network 203.0.0.2 0.0.0.0

auto-summary

!

router ospf 100

log-adjacency-changes

redistribute eigrp 35 metric 10

network 201.0.0.2 0.0.0.0 area 0

network 202.0.0.2 0.0.0.0 area 0

default-information originate

!

ip http server

no ip http secure-server

ip classless

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password cisco

login

!

ntp clock-period 17208153

ntp server 199.45.201.99

!

End


R4#show run

Building configuration...

Current configuration : 2243 bytes

!

! Last configuration change at 22:06:07 UTC Fri Dec 30 2016

! NVRAM config last updated at 22:06:35 UTC Fri Dec 30 2016

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R4

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 192.168.10.1 192.168.10.10

ip dhcp excluded-address 192.168.20.1 192.168.20.10

ip dhcp excluded-address 192.168.30.1 192.168.30.10

ip dhcp excluded-address 192.168.40.1 192.168.40.10

ip dhcp excluded-address 192.168.50.1 192.168.50.10

ip dhcp excluded-address 192.168.60.1 192.168.60.10

!

ip dhcp pool camaras

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

!

ip dhcp pool rrhh

network 192.168.20.0 255.255.255.0

default-router 192.168.20.1

!

ip dhcp pool ventas

network 192.168.30.0 255.255.255.0

default-router 192.168.30.1 255.255.255.0

!

ip dhcp pool finanzas

network 192.168.40.0 255.255.255.0

default-router 192.168.40.1

!

ip dhcp pool videoconferencia

network 192.168.50.0 255.255.255.0

default-router 192.168.50.1

!

ip dhcp pool visitas

network 192.168.60.0 255.255.255.0

default-router 192.168.60.1

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

voice-card 0

!

archive

log config

hidekeys

!

interface Loopback0

ip address 199.45.201.99 255.255.255.0

!

interface FastEthernet0/0

ip address 203.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/3/0

no ip address

shutdown

clock rate 125000

!

interface Serial0/3/1

no ip address

shutdown

clock rate 125000

!

router eigrp 35

redistribute static

network 203.0.0.1 0.0.0.0

auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Loopback0

no ip http server

no ip http secure-server

!

control-plane

!

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

voice-port 0/2/0

!

voice-port 0/2/1

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

ntp master

end